آموزش Vlan در میکروتیک سری CRS

امروز با آموزش Vlan  در سری میکروتیک های CRS یا همان Cloud Router Switch های میکروتیک با شما همراه هستیم. راه اندازی  Vlan با استفاده از قسمت Switch در میکروتیک های CRS بسیار بهتر است تا این که اینترفیس VLan در میکروتیک ساخته شود و بایک اینترفیس فیزیکی بریج شود . دلیل این میباشد که وقتی از Bridge استفاده میشود CPU دستگاه درگیر میشود و ThroughPut و کارایی پایین میایید و این که سری میکروتیک های CRS دارای CPU های ضعیفی هستند و چیپ ست Switch که تمام اینترفیس ها به آن متصل هستند قدرت بالایی دارد.

آموزش Port based Vlan

Port-Based-Vlan

در این مثال ۳ شبکه مختلف که بدون تگ Vlan هستند را از اینترفیس های Ether6,7,8 گرفته و آن هارا تگ گذاری میکنیم و از طریق اینترفیس Ether2 به صورت Trunk انتفال میدهیم.

گام اول

مستر پورت (MasterPort)  را برای اینترفیس های Ether6,7,8 روی اینترفیس Ether2 قرار میدهیم.

/interface ethernet
set ether6 master-port=ether2
set ether7 master-port=ether2
set ether8 master-port=ether2

گام دوم

برای اینترفیس های Ether6,7,8 یا Access Port ها Vlan ID ست میکنیم.

/interface ethernet switch ingress-vlan-translation
add ports=ether6 customer-vid=0 new-customer-vid=200 sa-learning=yes
add ports=ether7 customer-vid=0 new-customer-vid=300 sa-learning=yes
add ports=ether8 customer-vid=0 new-customer-vid=400 sa-learning=yes

گام سوم

برای اینترفیس Ether2 که Trunk Port میباشد Vlan ID هارا برای تگ گذاری مشخص میکنیم.

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether2 vlan-id=200
add tagged-ports=ether2 vlan-id=300
add tagged-ports=ether2 vlan-id=400

گام چهارم

سپس برای کامل شدن Isolation باید Vlan هارا در جدول Vlan اضافه کنیم. اضافه کردن اینترفیس ها به همراه Vlan ID باعث میشود که ترافیک برای آن پورت ها معتبر باشد.

/interface ethernet switch vlan
add ports=ether2,ether6 vlan-id=200 learn=yes
add ports=ether2,ether7 vlan-id=300 learn=yes
add ports=ether2,ether8 vlan-id=400 learn=yes

گام آخر

غیر فعال کردن unknown/invalid VLAN forwarding این کار باعث میشود که جلوی عبور Vlan های ناخواسته گرفته شود.

/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether2,ether6,ether7,ether8

دیدگاه ها:

  1. Ebrahim Mamani Ebrahim Mamani گفت:

    مشکلی که من با میکروتیک دارم و هنوز مطلبی قانع کننده نخوندم این هست که تو همه اموزشها یک پورت رو مستر پورت میکنن.

    من تو شبکه خودم نیاز به چند پورت ترانک دارم . هم این که یک بکاب برای لینک اصلی باشه هم ارتباط این سویچ با سویچ بعدی .

    تو سیسکو به هر پورت یه vlan میدی و بقیه پورتها رو ترانک میکنی تموم میشه .
    میخوام مثلا از پورت ۱ تا ۲۰ هر کدوم یه Vlan باشه و همه vlan ها بتونن از پورت ۲۱ تا ۲۴ عبور کنن تا به بقیه سویچها یا لینک بکاپ در زمان قطعی لینک لصلی که به پورت ۲۴ وصله دسترسی باشه

    لطفا اگه میشه راهنمایی کنید دوستان .

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

این مطلب را به اشتراک بگذارید...

منتشر شده در        ۸ شهریور ۱۳۹۶

امیر حسین فروزانی

امیر حسین فروزانی