آموزش راه اندازی Bonding در میکروتیک

خلاصه

Bonding در میکروتیک تکنولوژی است که اجازه میدهد چندین لینک اترنت باهم تجمیع شده و یک لینک مجازی را تشکیل دهند به طوری که قابلیت افزایش سرعت دیتا و امکان FailOver را فراهم میسازد.

 

راه اندازی Bonding در میکروتیک

 

در دیاگرام بالا روتر ۱ و روتر ۲ با ۲ لینک وایرلس مستقل به هم متصل هستند و آیپی برای اینترفیس وایرلس آنها ست شده است.

گام اول

از آن جایی که قابلیت Bonding فقط برای ارتباطات لایه ۲ میباشد (Ethernet ) ابتدا باید ۲ لینک EoIP بسازیم.

در روتر اول

[admin@MikroTik] > /interface eoip add remote-address=10.0.1.1/24 tunnel-id=1
[admin@MikroTik] > /interface eoip add remote-address=10.0.2.1/24 tunnel-id=2

 

در روتر دوم

[admin@MikroTik] > /interface eoip add remote-address=10.1.1.1/24 tunnel-id=1
[admin@MikroTik] > /interface eoip add remote-address=10.2.2.1/24 tunnel-id=2

 

گام دوم

برای ساخت اینترفیس Bonding بر روی ۲ اینترفیس EoIP به روش زیر عمل میکنیم.

روتر اول

[admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr

 

روتر دوم

[admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr

 

و در آخر میتوانید برای تست  بر روی اینترفیس ها IP ست کرده و پینگ نمایید.

روتر اول

[admin@MikroTik] > / ip address add address 192.168.0.1/24 interface=bonding1

 

روتر دوم

[admin@MikroTik] > / ip address add address 192.168.0.2/24 interface=bonding1

 

فعال سازی  Link Monitoring

در کانفیگ بالا با قطع شدن یک از لینک ها لینک Bonding قطع شده و ارتباط قطع خواهد شد. برای جلو گیری از این کار باید از Link Monitoring استفاده کرد.

 

روتر اول

[admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.2

 

روتر دوم

[admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.1

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

این سایت از اکیسمت برای کاهش هرزنامه استفاده می کند. بیاموزید که چگونه اطلاعات دیدگاه های شما پردازش می‌شوند.