راه اندازی Vlan درمیکروتیک

آموزش Vlan در میکروتیک

تعریف وی لَن: LAN در واقع یک Broadcast Domain است، ایجاد Virtual LAN نیز یعنی تفکیک یک Broadcast Domain به دو یا چند Broadcast Domain جدا از هم!

به عبارت دیگر ایجاد Vlan درست مانند آن است که یک سوئیچ با تعداد پورت بیشتر را به چند سوئیچ با تعداد پورت کمتر تقسیم نماییم.

مثال اول

راه اندازی Vlan در میکروتیک به صورت Access و Trunk با استفاده از Switch

در شکل بالا همان طور که می بینید اینترفیس Ether2 اینترفیس Trunk میباشد (Tagged) و اینترفیس های Ether3,4,5 اینترفیس های Access هستند (Untagged) . یعنی اینترفیس ۲ ما فریم های تگ شده را دریافت میکند و سپس چیپست قسمت سویچ روتر ما با توجه به تگ آن اینترفیس مربوطه میفرستد.

مرحله اول

مستر پورت (Master Port) را برای تمامی اینترفیس های Access  اینترفیس Trunk قرار میدهیم که در سناریوی ما به صورت زیر خواهد بود:

/interface ethernet
set ether3 master-port=ether2
set ether4 master-port=ether2
set ether5 master-port=ether2

توجه :  این عمل فقط برای اینترفیس های که در یک گروه هستند امکان پذیر است

مرحله دوم

به قسمت Switch -> Vlan میرویم و ورودی های زیر را اضافه میکنیم تا امکان جابه جای فریم ها با Vlan ID خاص بین اینترفیس های مورد نظر بوجود آید.

/interface ethernet switch vlan
add ports=ether2,ether3 switch=switch1 vlan-id=200
add ports=ether2,ether4 switch=switch1 vlan-id=300
add ports=ether2,ether5 switch=switch1 vlan-id=400

مرحله آخر

برای اینترفیس های مورد نظر Vlan ID اختصاص میدهیم

/interface ethernet switch port
set ether2 vlan-mode=secure vlan-header=add-if-missing
set ether3 vlan-mode=secure vlan-header=always-strip default-vlan-id=200
set ether4 vlan-mode=secure vlan-header=always-strip default-vlan-id=300
set ether5 vlan-mode=secure vlan-header=always-strip default-vlan-id=400

مثال دوم

راه اندازی Vlan در میکروتیک به صورت Access و Trunk با استفاده از Bridge

در این مثال ما بجای استفاده از switch از قابلیت Bridge استفاده میکنیم (در این حالت مصرف CPU روتر بیشتر است ) این حالت برای روتر های مناسب است که امکان Switch  را ندارند مانند سری CCR

مرحله اول

اینترفیس های Vlan را با آیدی های مورد نظر برای اینترفیس Trunk میسازیم

/interface vlan
add interface=ether2 name=eth2-vlan200 vlan-id=200
add interface=ether2 name=eth2-vlan300 vlan-id=300
add interface=ether2 name=eth2-vlan400 vlan-id=400

مرحله دوم

سپس برای هر کدام یک از Vlan ها یک اینترفیس Bridge میسازیم

 /interface bridge
add name=bridge-vlan200
add name=bridge-vlan300
add name=bridge-vlan400

مرحله سوم

و در آخر اینترفیس های Access را به Bridge ها اضافه میکنیم

/interface bridge port
add bridge=bridge-vlan200 interface=eth2-vlan200
add bridge=bridge-vlan200 interface=ether6
add bridge=bridge-vlan300 interface=eth2-vlan300
add bridge=bridge-vlan300 interface=ether7
add bridge=bridge-vlan400 interface=eth2-vlan400
add bridge=bridge-vlan400 interface=ether8

دیدگاه ها:

  1. Ebrahim Mamani Ebrahim Mamani گفت:

    برای ارتباط با سویچهای دیگر هیچ راهکاری وجود نداره تو میکروتیک ؟
    اگه مستر پورت بدیم که فقط همون پورت میشه trunk

    من میخوام ۴ تا پورت بصورت ترانک باشه همه Vlan ها رو عبور بده بقیه تک تک یه Vlan برا خودشون داشته باشند .

    در حالت بریج ۴ تا پورت رو بریج میکنم روی برج vlan اضافه میکنم و هر vlan رو با یه پورت تو یه برج جدا میزارم – معایب بالا رفتن بار CPU و برادکست اضافه روی پورتهای ترانکی که بار روش نیست –

    در حالت استفاده از Swiching هم که نمیشه ۴ تا پورت رو با هم یکی کرد و ترانک داشت .

    چهار تا خط دستور سیسکو رو اخرش معادل براش تو میکروتیک پیدا نکردم .

    پورت ۱ تا ۲۰ vlan 1 تا vlan 20
    پورت ۲۱ تا ۲۴ ترانک باشه

    یه حالت دیگه هم میخوام که پورتهای ترانک Vlan های دیگه که از یه سوچ دیگه به سویچ دیگه هست رو رد کنه مثلا vlan 40 تا ۶۰ رو هم بتونه انتقال بده به سویچ بعدی با همون ۴ تا پورت ترانک

    ممنون میشم کمکم کنید .

    1. باید از مستر پورت استفاده کنید و مستر پورت را با ۳لینک دیگه بریج کنید

      برای مورد دوم هم باید از Q in Q استفاده کنید

  2. با سلام و اخترام
    من یک سناریو برای شبکه دارم که ۲ تا سرویس اینترنت و MPLS را با دو تا vlan متفاوت روی یک پورت روتر دریافت می کنم و با یک پورت دیگر به شبکه داخلی متصل می کنم الان نمی توانم اینترنت را تحت این سناریو به شبکه داخلی ارائه کنم؟لطفاً راهنمایی می کنید؟

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

این سایت از اکیسمت برای کاهش هرزنامه استفاده می کند. بیاموزید که چگونه اطلاعات دیدگاه های شما پردازش می‌شوند.